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1) Uruchom program Adobe Illustrator. Utwórz nowy plik, niech będzie w trybie RGB, 
jako jednostki wygodnie będzie ustawić pixele (Units -> Pixels). Narysuj chmurę.

   

2) Wyeksportuj ją (File -> Export) do formatu Macromedia Flash .SWF.

   



3) W Export As wybierz AI File to SWF File (dzięki czemu z pliku Illustratora 
powstanie wynikowy plik Flasha). Ustaw maksymalną jakość krzywej (Curve 
Quality). Następnie w nowym pliku narysuj piorun i wyeksportuj tak samo jak 
chmurę.

   

4) Stwórz nowy plik i narysuj słońce i wyeksportuj tak jak chmurę. Następnie w 
nowym pliku narysuj dużo kropelek i ustaw je powyżej obszaru pracy (Artboard) i 
zgrupuj.

   



5) Skopiuj całą warstwę wraz z jej zawartością - przeciągając w palecie Layers 
warstwę na ikonę przycisku tworzenia nowej warstwy. Przesuń grupę elementów 
trochę ku dołowi i ponownie skopiuj bieżącą warstwę. Postępuj tak, aż krople 
'przelecą' przez Artboard (warto by było tak na nie mniej niż 15-20 warstwach).

   

6) Wyeksportuj kropelki do Flasha, jednak tym razem by uzyskać animowaną wersję 
dokumentu, wybierz w opcjach eksportu - tworzenie z poszczególnych warstw 
Illustratora, poszczególnych klatek w pliku .SWF (Export As -> AI Layers to SWF 
Frames).

   



7) W prędkości odtwarzania wpisz 25 klatek na sekundę (Frame Rate 25 fps), a 
następnie zakliknij Looping, czyli odtwarzanie zapętlone.

   

8) Zaznacz też obcinanie eksportowanego pliku do rozmiaru formatu pracy 
(Artboardu) czyli Clip to Artboard Size.

   

9) Narysuj w nowym pliku poziomą 'linijkę' z nazwami miesięcy, litery zamień na 
krzywe i (Type -> Create Outlines) wyeksportuj tak jak chmurę.

   



10) Narysuj w nowym pliku trójkącik (będzie wskazywał bierzący miesiąc) 
i wyeksportuj tak jak chmurę.

   

11) Uruchom program Macromedia Flash i utwórz w nim nowy dokument
(File -> New).

   

12) W palecie Documents kliknij przycisk obok Size i w oknie Documents Properities 
wpisz rozmiary dokumentu na 768x576 i prędkość 25 fps.

   



13) Zaimportuj do biblioteki (File -> Import -> Import to Library) wszystkie 
przygotowane uprzednio dokumenty, mające być elementami Twojego diagramu. 
Oprócz przygotowanych w Illustratorze plików .SWF zaimportuj też uprzednio 
przygotowane mapy terenu (w wypadku importowania takich plików jak .PSD czy 
.TIFF Flash moze mieć problemy - jeśli jednak masz zainstalowanego QuickTime - 
dokona on konwersji w 'locie' na życzenie Flasha - potwierdź tylko klawiszem OK).
Przygotowałem cztery mapy o zmiennych cechach wyglądu powiązanych z porami 
roku (śnieg itp.).

   

14) W wyniku tego działania w Bibliotece masz zestaw elementów niezbędny do 
stworzenia animacji - diagramu.



15) Wskarz w bibliotece pierwszą mapę ('zima.tif') i przeciągnij na pole robocze, 
i ułóż w żądanym położeniu (narzędziem 'czarna strzałka').
W palecie Timeline zmień nazwe warstwy na 'ziemia dol' (aby zmienić nazwę kliknij 
dwa razy w bieżącą nazwę warstwy).

   

16) W klatce 70 na warstwie 'ziemia dol' dodaj nowy klucz (kliknij prawym klawiszem 
myszy i wybierz Insert Keyframe).

   



17) Powstała klatka kluczowa (oznaczona czarnym kółkiem w swojej dolnej połowie). 
Wrzuć planszę 'wiosna2.tif' i ustaw w odpowiedniej pozycji.
Na klatce 180 kliknij prawym klawiszem i ponownie dodaj klucz.

   

18) W palecie Timeline kliknij w ikonę New Layer by utworzyć nową warstwę.
Nazwij ją 'ziemia gora'.

   

19) W tej warstwie na klatce 40 dodaj klatkę kluczową.



20) Wrzuć na pole robocze planszę 'wiosna'. Kiedy będzie już na polu roboczym 
kliknij w 'wiosna.tif' prawym klawiszem myszy i zmień ją na symbol (Convert to 
Symbol).

   

21) Nazwij go wiosna i wybierz typ: Movie clip i kliknij OK. Na klatce 50 dodaj klucz.

   

23) Kliknij prawym klawiszem pomiędzy klatkami 40 i 50 i wybierz polecenie Create 
Motion Tween. Następnie zaznacz tylko klatkę 40 i kliknij w obszar roboczy i ustaw 
parametr Color na wartość Alpha (regulacja przezroczystości objektu).

   



24) Wartość Alpha ustaw na 0% dzięki czemu obiekt będzie płynnie przechodził od 
klatki 40 gdzie jest przezroczysty, do klatki 50 gdzie jest całkowicie kryjący 
(automatyczne przejście zapewnia wybrany uprzednio Motion Tween).
W klatce 100 dodaj klucz, a kolejny w 120 (ciągle na warstwie 'ziemia gora').

   

25) Pomiędzy klatkami 100 i 120 dodaj Motion Tween, a następnie w klatce 120 
ustaw całkowitą przezroczystość 'objektu wiosna'.

   



26) Dodaj klucz w klatce 125, kliknij dwókrotnie pomiędzy klatkami 125, a 180 
i wykasuj ich zawartość (Edit -> Clear).
Dodaj klucz w klatce 140.

   

27 Wrzuć na pole robocze objekt 'lato.tif', ułóż poprawnie i kliknij prawym klawiszem 
myszy, poczym wybierz Convert to Symbol.

   

28) Nazwij 'lato' i wybierz typ Movie clip.



29) Kliknij w objekt i w Color nastaw Alpha o wartości 0%.

   

30) W klatce 150 dodaj klucz i wartość Alpha zmień na 100%.

   

31) Pomiędzy klatkami 140 i 150 dodaj Motion Tween. W klatce 200 dodaj jeszcze 
jeden klucz (będzie to ostatnia klatka animacji). Aby sprawdzić działanie tego co 
powstało dotychczas wybierz Control -> Test Movie (aby powrócić do pracy poprostu 
zamknij okno z animowanym podglądem).



32)  W palecie Timeline dodaj nową teczkę (klikając w ikone New Folder), nazwij ją 
'ziemia', wrzuć do niej obie warstwy (pamiętaj o zachowaniu poprawnej kolejności).

   

33) Gdyby warstwy ułożyły się w teczce odwrotnie, popraw to przeciągając je na 
odpowiednie pozycje. Nie zapomnij zablokować teczki 'ziemia' (kliknij w kropkę pod 
ikoną kłódki - kropka zmieni się na kłódkę).
Utwórz nową warstwę, umieść ją powyżej teczki 'ziemia'.

   



34) Nazwij ją 'wskaznik'. Wrzuć na pole robocze objekt 'wskaznik'.

   

35) Narzędziem do przesuwania i selekcji (czarna strzałka) i do zmiany wielkości i 
ułożenia (Free Transform) umieść objekt we właściwym miejscu (i wielkości).

   

36) Dodaj nową warstwę i nazwij ją 'miesiące' i wrzuć na obszar roboczy objekt 
miesiące z palety Library. Ułoż go tak by strzałka wskazywała datę pomiędzy 
grudniem, a styczniem.

   



37) Dodaj klucz w klatce 200 (na warstwie 'miesiace'). Przesuń na obszarze 
roboczym objekt 'miesiące' tak by strzałka wskazywała pomiędzy lipiec, a sierpień.

   

38) Dodaj Motion Tween i już licznik miesięcy działa. Możesz sprawdzić poprzez 
Control -> Test Movie. Stwórz teczkę, wrzuć do niej obie warstwy, teczkę zablokuj
 i nazwij 'licznik'.

   



39) W palecie Library kliknij prawym klawiszem myszy na objekt 'slonce' i przerób go 
na Movie Clip.

   

40) Dodaj nową warstwę i nazwij ją 'słońce'. W klatce 150 dodaj klucz i wrzuć objekt 
'slonce' z palety Library.

   



41) W klatce 155 dodaj klucz i wrzuć na obszar roboczy kolejne słońce. W klatce 175 
dodaj kolejny klucz i wrzć kolejne słońce.
Sprawdż działanie animacji (Control -> Test Movie).

   

42) Stwórz nową warstwę i nazwij ją 'chmury'. Z palety Library wrzuć na obszr 
roboczy objekt 'chmura'.

   



43) Kliknij weń prawym klawiszem myszy i przerób na symbol Movie clip o nazwie 
'chmura symbol'.

   

44) Umieść go w odpowiednim miejscu, a następnie wrzuć na obszar roboczy 
jeszcze dwa objekty 'chmura objekt' i umieść we właściwych miejscach.

   

45) W klatce 150 na warstwie chmury dodaj klucz.

   



46) Wybierz z Toolboxa narzędzie o ikonie białej strzałki, zaznacz nią chmurę 
w prawym górnym roku i usuń (Edit -> Clear).

   

47) W klatce 155 na warstwie 'chmury' dodaj klucz.
Następnie zaznacz białą strzałką i usuń prawą górną chmurę.

   

48) W klatce 175 na warstwie 'chmury' dodaj klucz.

   



49) Następnie zaznacz białą strzałką i usuń ostatnią chmurę. Sprawdź działanie 
animacji (Control -> Test Movie). Jeśli wszystko zrobiłeś poprawnie to w tej chwili na 
animacji wraz z upływem czasu, zanika śnieg, a następnie pojawia się na ziemi 
trawa, która w miarę upływu czasu zaczyna usychać. Jednocześnie pod koniec 
animacji (miesiące wiosenne i letnie) wypogadza się niebo nad naszymi trzema 
przykładowymi miejscowościami. Pozostaje więc w miesiącach zimowych 
i wiosennych dodać od czasu do czasu opady (niekiedy z występowaniem 
piorunów). 

   

50) W palecie Timeline zablokuj warstwy 'chmury' i 'slonce', a następnie dodaj nową 
warstwę.

   



51) Umieść ją pomiędzy warstwami 'chmury' i 'slonce' i nazwij 'deszcze'.

   

52) W warstwie 'descze' w klatce 15 dodaj klucz.

   

53) Z palety Library wrzuć na obszar roboczy objekt 'krople'. Umieść go tak by 
delikatnie wystawał z pod chmury.

   



54) Na klatce 45 w warstwie 'deszcze' dodaj klucz. Następnie skasuj 'krople' (Edit -> 
Clear). Wypróbuj animację (Control -> Test Movie). W ten sposób spowodowałeś 
opady deszczu, z jednej z chmur w czasie pomiędzy styczniem, a lutym.

55) W analogiczny sposób jak w punktach 52-54 w innych okresach czasu dodaj 
opady z innych chmur. 

   



56) Zablokuj warstwę 'deszcze'. Dodaj nową warstwę, nazwij ją burze, umieść 
pomiędzy warstwami 'chmury' i 'deszcze'.

   

57) Na warstwie 'burze' w klatce 20 dodaj klucz.
Wrzuć z palety Library objekt 'piorun' i umieść go pod prawą, górną chmurą.

   

   



58) Zaznacz na warstwie 'burze' klatkę 21 i dodaj w niej klucz.

   

59) Narzędziem czarna strzałka przesuń piorun w trochę inne położenie. W celu 
ułatwienia sobie pracy - możesz potrzebować znać położenie pioruna, w klatce 
poprzedzającej. Umożliwi Ci to opcja Onion Skin. Steruje się jej działaniem przy 
użyciu przycisków w palecie Timeline. Wciśnij najpierw skrajny lewy z wskazanych 
przycisków. Zobaczysz blady ślad pioruna z poprzedniej klatki, dwa kolejne przyciski 
pozwalają włączyć wyświetlanie śladu z poprzedniej klatki w postaci konturowej lub 
w pełni kryjącej.

   



60) Podobnie jak w punktach 58-59 dodaj parokrotnie w kolejnych klatkach klucze, 
za każdym razem przemieszczając trochę piorun (możesz też trochę go obracać lub 
skalować). W ostanim dodanym kluczu usuń piorun (Edit -> Clear). Sprawdź 
działanie animacji (Control -> Test Movie).
Następnie powtórz te operacje (klucz, dodanie pioruna, klucz, przesuniecie pioruna, 
klucz, przesunięcie pioruna,... ..., klucz, usunięcie pioruna) w innej częsci animacji 
przy innej chmurze.
Kiedy zakończysz dodawanie piorunów zablokuj warstwę 'burza'.

   

61) W zasadzie można by na tym etapie zakończyć konstruowanie animacji. 
Jednakże zapewne oglądając jej działanie (Control -> Test Movie), zauważyłeś, że 
dynamika zmian w niektórych częsciach animacji, lub sam ich moment nastąpienia 
nie zawsze jest najlepiej dobrany. W celu poprawienia tej sytuacji możesz zmieniać 
położenie kluczy na linii czasu zmieniając monent następowania jak i dynamikę 
opisanych nimi zdarzeń. W tym celu (na odpowiedniej warstwie) kliknij w w klucz 
który chcesz przesunać (w celu jego zaznaczenia), a następnie przeciągnij na nową 
pozycję (chwytając za czarną kropeczkę w jego dolnej części).
Po dokonaniu zmian, sprawdź ich działanie (Control -> Test Movie).

   



62) Innym sposobem dokonywania (globalnych) zmian jest przeróbka elementu 
w bibliotece (Library) - spowoduje ona analogiczną zmianę - wszystkich 
zastosowanych w animacji objektów z tego wzorca. Przykładowo przeróbmy obiekt 
'slonce'.
W palecie Library zaznacz obiekt 'slonce.swf' i kliknij w niego prawym klawiszem 
myszy. Wybierz polecenie Edit.

   

63) Na obszarze roboczym pjawi się zawartość objektu 'slonce'. Zaznacz na 
obszarze roboczym słońce, klikając weń myszą (musisz mieć wybrane narzędzie 
czarna strzałka). Następnie w palecie Timeline dodaj klucz w warstwie 40.



64) Wybierz w Toolboxie narzędzie Free Transform i obróć troche słońce.

   

65) Następnie pomiędzy klatkami 1 i 40 utwórz Motion Tween.
W celu powrócenia do projektu animacji, kliknij w niebieską strzałkę.
Wypróbuj zmiany (Control -> Test Movie).

   

66) Kiedy wreszczie zakończysz wprowadzanie poprawek w animacji. Wyeksportuj 
ją do formatu Flasha (File -> Export -> Export Movie).



67) W opcji Format nastaw Flash Movie i kliknij Save, a następnie wybierz w Version 
opcję Flash Player 5 i kliknij w OK.

   

68) Po chwili w wybranym przez Ciebie miejscu powstal plik .SWF. Plik taki można 
wykorzystać jako element strony interenetowej, fragment większej prezentacji 
wykonywanej np: w Flashu czy Directorze.
Można też przerobić go na samodzielną aplikację nie wymagającą do odtwarzania, 
jakigokolwiek dodatkowego programu w komputerze odbiorcy (np: przeglądarki stron 
WWW z zainstalowanym odpowiednim modułem Flasha). W tym celu otwórz 
świerzopowstały plik .SWF z Twoją animacją w programie SAFlashPlayer....

   



69) ...i nagraj jako samodzielną aplikację poleceniem File -> Create Projector.
W ten sposób uzyskujesz aplikację zgodną z systemem na którym pracujesz.
Aplikacja SAFlashPlayer dostępna jest na platformy Windows, MacOs (Classic)
i MacOs X.

   

70) Możesz też użyć swoją animację jako materiał wideo (samodzielny, lub jako 
element większej całości montowany potem np: w aplikacjach takich jak Adobe 
AfterEffects, Adobe Premiere, Apple FinalCutPro, Apple iMovie i wielu, wielu innych).
W tym celu możesz swoją animacje w pliku .SWF przekonwertować do 
odpowiedniego standardu cyfrowego wideo za pomocą aplikacji QuickTimePlayer.
W tym celu otwórz swój plik w QuickTime Playerze (musisz mieć zarejestrowaną 
wersję QuickTimePro!).
Wybierz polecenie File -> Export.

   



71) W oknie opcji exportu możesz nastawić żądany format pliku w parametrze 
Export (w tym wypadku wybrałem format .MP4 czyli MPEG4), dodatkowo opcje 
eksportu możesz wyregulować przyciskiem Options).
Kliknij w niego.

72) W zakładce General, w parametrze Size, wybierz Current - dzięki temu rozmiar 
filmu nie ulegnie zmianie. Przejdź do zakładki Video. Ustaw w niej prędkość 
odtwarzania na taką, jaką miałeś we Flashu (Frames per second -> 25). Wpisując 
w okienku Key frame every wartość większą niż 1, redukujesz rozmiar filmu kosztem 
płynności ruchu (raczej nie ustawiaj wartości większych niż w polu Frames per 
second!), a suwakiem do parametru kbits/seconds możesz regulować wielkość pliku 
kosztem jakości obrazu (suwak w prawo to większy plik ale z lepszym obrazem, w 
lewo na odwrót).

   


